当前位置:代码狗 > 经验教程 > 实用教程 > 正文

宝塔面板通用破解教程亲测可用

曾经我也是非常介意使用宝塔面板的,现在仍然介意,但在某些情况下宝塔面板确实很方便。使用过宝塔面板的站长都应该知道,宝塔面板很多安全相关功能都是以收费插件提供的,虽然不是特别贵,但也不是每个个人站长都会买的,那么如何破解这个收费问题呢?网上很多教程,亲测成功,一起来学习下吧。

宝塔面板通用破解教程亲测可用

宝塔面板通用破解教程亲测可用

第一步,破解面板。

打开/www/server/panel/class/panelPlugin.py文件,将

return softList

改为

softList['pro'] = 1

for soft in softList['list']:

 soft['endtime'] = 0

return softList

注意,对照下图查找需要修改的地方。

宝塔面板通用破解教程亲测可用

宝塔面板通用破解教程亲测可用

然后重启面板,你会发现你的面板已经变成专业版了,收费插件也不会收费了。

特殊插件破解

有几个插件仅仅破解面板仍然不能用,还需要再进行一次破解,如下:

网站监控报表插件破解

先下载安装插件,然后打开/www/server/panel/plugin/total/total_main.py文件,将def __get_mod函数中的

if ‘bt_total’ in session: return public.returnMsg(True,’OK!’);

改为

session['bt_total'] = True
return public.returnMsg(True,'OK!');

然后重启面板,即可正常使用。

宝塔面板通用破解教程亲测可用

宝塔面板通用破解教程亲测可用

Nginx防火墙破解

由于新版防火墙与旧版不同,新版加了密,为了方便我这里提供了破解文件,直接覆盖原文件即可。

安装完插件后,点击插件目录,即可自动打开插件目录,然后下载文末的破解文件包,将对应文件夹中的文件上传到宝塔插件对应文件夹,覆盖即可。

宝塔面板通用破解教程亲测可用

宝塔面板通用破解教程亲测可用

然后启动插件,将里面禁止国外访问选项关闭。

宝塔面板通用破解教程亲测可用

宝塔面板通用破解教程亲测可用

现在很多插件都是以so加密文件提供的,想要改代码破解有难度,但是可以利用以前的文件覆盖。。。这里只是以防火墙为例,其它插件破解以此类推。

注意:如果出现如下报错,请检查你的代码格式,空格与TAB不能混用!

Traceback (most recent call last):
File "class/panelPlugin.py", line 1572, in a
plugin_main = __import__(get.name+'_main');
File "/usr/lib64/python2.7/site-packages/gevent/builtins.py", line 96, in __import__
result = _import(*args, **kwargs)
File "plugin/total/total_main.py", line 171
tu = '/proc/sys/net/ipv4/tcp_tw_reuse'
^
IndentationError: unexpected indent

文件下载

要查看更多文章内容,请您先登录/注册

感觉很棒!可以赞赏支持我哟~

赞(2) 打赏

评论 12

  1. #7

    https://www.iamwawa.cn/ 狗哥 这网站的工具哪里有么?

    riven1天前回复
    • 不知道

      代码狗5小时前回复
  2. #6

    主要是够不够稳定!

    缙哥哥2周前 (09-09)回复
  3. #5

    感谢分享,Nginx防火墙那个文件是放错了还是标错了?标的是.so文件,放的是.py文件

    小不点2周前 (09-06)回复
    • so是加密文件,py是以前没加密的。

      代码狗2周前 (09-06)回复
  4. #4

    非常感谢,按照教程确实能用不少,但是发现Nginx防火墙7.5不行 还是提示未授权,文件已经用替换过了。

    空空小名3周前 (09-04)回复
    • 操作不正确,我的7.5正在用

      代码狗3周前 (09-04)回复
  5. #3

    狗哥,你是什么版本的?我的6.8.9死活破解不了,直接复制粘贴你的代码过去软件商店就没东西了,不显示插件列表了.重启服务器都不行

    朴尘轻轩3周前 (09-03)回复
    • 我的是6.9.8,其它版本应该都可以,可能是你的代码格式有问题,Python这种语言对格式要求特别严格,仔细检查空格和tab

      代码狗3周前 (09-03)回复
  6. #2

    学习了,不知道能破解什么版本的呢

    学习3周前 (09-02)回复
    • 理论上都可以

      代码狗3周前 (09-02)回复
  7. #1

    厉害了,这也行

×

请作者吃根烤肠!

支付宝